SurfaceBooleanSubtract(Surface) Method
|
Performs a Boolean subtraction operation
between this surface and other surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Surface BooleanSubtract(
Surface surface2
)
Public Overridable Function BooleanSubtract (
surface2 As Surface
) As Surface
public:
virtual Surface^ BooleanSubtract(
Surface^ surface2
)
abstract BooleanSubtract :
surface2 : Surface -> Surface
override BooleanSubtract :
surface2 : Surface -> Surface
Parameters
- surface2 Surface
- [in] Surface to be subtracted from this surface.
Return Value
Surface
Surface that represents the subtraction operation result.
Remarks
This method is
implemented only for the ModelerGeometry and Spatial modelers. If
this surface is not derived from the Surface class, the result is
stored in this surface. Otherwise, this surface is not changed and
the resulting surface is returned by the method. If the resulting
surface is empty, the method throws the eNoIntersections exception,
returns NULL, and this surface is not changed. If the subtraction
operation fails, the method returns NULL, and this surface is not
changed.
See Also