ApplicationShowModalDialog(IWin32Window,
Form, Boolean) Method
|
Shows a modal dialog. When ShowModalDialog is
used, an event is attached to preserve the location and size of
dialog
Namespace: Bricscad.ApplicationServices
Assembly: BrxMgd (in BrxMgd.dll) Version:
24.0.1.0
Syntax
public static DialogResult ShowModalDialog(
IWin32Window owner,
Form form,
bool persist
)
Public Shared Function ShowModalDialog (
owner As IWin32Window,
form As Form,
persist As Boolean
) As DialogResult
public:
static DialogResult ShowModalDialog(
IWin32Window^ owner,
Form^ form,
bool persist
)
static member ShowModalDialog :
owner : IWin32Window *
form : Form *
persist : bool -> DialogResult
Parameters
- owner IWin32Window
- Form Owner
- form Form
- Form to Show
- persist Boolean
- option to persist size and location
Return Value
DialogResult
System::Windows::Forms::DialogResult
See Also