Application Class

This class exposes methods and properties of the Bricscad Application. Use this class for accessing the AcadApplication ActiveX object, Showing dialogs and application related events.
Inheritance Hierarchy
SystemObject
  Bricscad.ApplicationServicesApplication

Namespace: Bricscad.ApplicationServices
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public sealed class Application

The Application type exposes the following members.

Properties
Methods
  Name Description
Public methodStatic member AddDefaultContextMenuExtension  
Public methodStatic member AddObjectContextMenuExtension  
Public methodStatic member DoDragDrop  
Public methodStatic member GetSystemVariable Gets a System Variable
Public methodStatic member InvokeHelp Displays the Help window. This function displays a help file. The two arguments are passed to the Windows Help engine. The argument help file specifies name of the HLP file. The id argument specifies the topic ID string, which brings up a specific topic, such as a command name. When missing, IntelliCAD® displays the first topic of the Help file.
Public methodStatic member IsMenuGroupLoaded  
Public methodStatic member LoadPartialMenu  
Public methodStatic member Quit  
Public methodStatic member RemoveDefaultContextMenuExtension  
Public methodStatic member RemoveObjectContextMenuExtension  
Public methodStatic member SetSystemVariable Sets a System Variable
Public methodStatic member ShowAlertDialog Display an alert or message for the user. This function displays a dialog box containing the string. This provides information to the user and includes only the OK button. The argument str is the text to be displayed in the dialog box. This string may contain new-line characters to present the text more clearly.
Public methodStatic member ShowModalDialog(Form) Shows a modal dialog. When ShowModalDialog is used, an event is attached to preserve the location and size of dialog
Public methodStatic member ShowModalDialog(IWin32Window, Form) Shows a modal dialog. When ShowModalDialog is used, an event is attached to preserve the location and size of dialog
Public methodStatic member ShowModalDialog(IWin32Window, Form, Boolean) Shows a modal dialog. When ShowModalDialog is used, an event is attached to preserve the location and size of dialog
Public methodStatic member ShowModalWindow(Window) Shows a modal dialog form, persisting size and position.
Public methodStatic member ShowModalWindow(IntPtr, Window) Shows a modal dialog form, persisting size and position.
Public methodStatic member ShowModalWindow(Window, Window) Shows a modal dialog form, persisting size and position.
Public methodStatic member ShowModalWindow(IntPtr, Window, Boolean) Shows a modal dialog form.
Public methodStatic member ShowModalWindow(Window, Window, Boolean) Shows a modal dialog form.
Public methodStatic member ShowModelessDialog(Form) Show Modeless Dialog. When ShowModelessDialog is used, an event is attached to preserve the location and size of dialog
Public methodStatic member ShowModelessDialog(IWin32Window, Form) Show Modeless Dialog. When ShowModelessDialog is used, an event is attached to preserve the location and size of dialog
Public methodStatic member ShowModelessDialog(IWin32Window, Form, Boolean) Show Modeless Dialog. When ShowModelessDialog is used, an event is attached to preserve the location and size of dialog
Public methodStatic member ShowModelessWindow(Window) Shows a modeless dialog form, persisting size and position.
Public methodStatic member ShowModelessWindow(IntPtr, Window) Shows a modeless dialog form, persisting size and position.
Public methodStatic member ShowModelessWindow(Window, Window) Shows a modeless dialog form, persisting size and position.
Public methodStatic member ShowModelessWindow(IntPtr, Window, Boolean) Shows a modeless dialog form.
Public methodStatic member ShowModelessWindow(Window, Window, Boolean) Shows a modeless dialog form.
Public methodStatic member ToSystemDrawingPoint  
Public methodStatic member ToSystemDrawingSize  
Public methodStatic member ToSystemWindowsPoint  
Public methodStatic member ToSystemWindowsSize  
Public methodStatic member UnloadPartialMenu  
Public methodStatic member UpdateScreen Updates the graphics screen.
Top
Events
See Also

©  Bricsys NV. All rights reserved.