NewLayerNotification Enumeration

This enum relates to the LAYERNOTIFY header variable.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
[FlagsAttribute]
public enum NewLayerNotification
Members
Member name Value Description
NoNewLayerNotification 0 All notification states are turned off.
NotifyOnPlot 1 Notification whenever new layers exist and plotting is about to start.
NotifyOnOpen 2 Notification whenever new layers exist when a drawing is first opened.
NotifyOnXrefAttachAndReload 4 Notification whenever new layers exist in an external reference and the external reference is currently attached or reloaded.
NotifyOnLayerStateRestore 8 Notification whenever new layers are created by restoring a layer state.
NotifyOnSave 16 Notification whenever new layers exist and the drawing is currently saved.
NotifyOnInsert 32 Notification whenever new layers are created by inserting a block.
See Also

©  Bricsys NV. All rights reserved.