NurbCurve3dFitData Structure

This structure stores the data returned by the NurbCurve3d.FitData property.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryNurbCurve3dFitData

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct NurbCurve3dFitData

The NurbCurve3dFitData type exposes the following members.

Properties
  Name Description
Public property Degree  
Public property EndTangent  
Public property FitPoints  
Public property FitTolerance  
Public property KnotParam  
Public property StartTangent  
Public property TangentsExist  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo Checks whether this nurb curve fit data is equal to the passed nurb curve fit data.
Top
Operators
  Name Description
Public operatorStatic member Equality(NurbCurve3dFitData, NurbCurve3dFitData) Equality operator for the NurbCurve3dFitData structure. Checks whether curve data is equal.
Public operatorStatic member Inequality(NurbCurve3dFitData, NurbCurve3dFitData) Inequality operator for the NurbCurve3dFitData structure. Checks whether curve data is not equal.
Top
See Also

©  Bricsys NV. All rights reserved.