KnotCollectionSplit Method
|
Splits this vector at the point corresponding
to the passed parameter.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public KnotCollection[] Split(
double parameter,
int multiplicityLast,
int multiplicityFirst
)
Public Function Split (
parameter As Double,
multiplicityLast As Integer,
multiplicityFirst As Integer
) As KnotCollection()
public:
array<KnotCollection^>^ Split(
double parameter,
int multiplicityLast,
int multiplicityFirst
)
member Split :
parameter : float *
multiplicityLast : int *
multiplicityFirst : int -> KnotCollection[]
Parameters
- parameter Double
- [in] Parameter at which this collection is split.
- multiplicityLast Int32
- [in] Multiplicity of the last knot in the head portion.
- multiplicityFirst Int32
- [in] Multiplicity of the first knot in the tail portion.
Return Value
KnotCollection
Array of two knot collections (after splitting). Indices: * 0 - the
head portion of the split. * 1 - the tail portion of the
split.
See Also