KnotCollection Class

This class represents an ordered series of uniformly increasing doubles used by spline entities.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryKnotCollection

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class KnotCollection : DisposableWrapper, 
        IList

The KnotCollection type exposes the following members.

Constructors
  Name Description
Public method KnotCollection Default constructor for the KnotCollection class.
Top
Properties
  Name Description
Public property Count  
Public property EndParameter  
Public property IsFixedSize Property that indicates whether this collection has a fixed size.
Public property IsReadOnly Property that indicates whether this collection is read-only.
Public property IsSynchronized Property that indicates whether access to this collection is thread-safe.
Public property Item Property that represents an item from the collection at the specified index.
Public property NumberOfIntervals  
Public property StartParameter  
Public property SyncRoot Property that represents an object that can be used to synchronize access to this collection.
Public property Tolerance  
Top
Methods
  Name Description
Public method Add Appends a single knot to this vector, and returns the value of the single knot.
Public method Clear  
Public method Contains Checks whether the specified parameter is between the first and last knots.
Public method CopyTo Copies this knot collection to the specified array.
Public method GetDistinctKnots Returns a set of unique knots (i.e. knots without repetitions) in this knot collection.
Public method GetEnumerator Returns an enumerator object for this knot collection.
Public method GetInterval Returns the knot interval, and the index of the knot interval, containing the point specified by param.
Public method GetMultiplicityAt Returns knot multiplicity (repetitions) of the knot value at the specified index.
Public method Insert Inserts the specified knot at the specified index.
Public method IsOn Checks whether the specified knot is a member of this knot collection within the knot equality tolerance.
Public method RemoveAt Removes the specified knot from this knot collection.
Public method Reverse Reverses the order of this knot collection.
Public method SetRange Transforms this vector such that the first knot has the value of the lower parameter, and the last knot has the value of the upper parameter.
Public method Split Splits this vector at the point corresponding to the passed parameter.
Top
See Also

©  Bricsys NV. All rights reserved.