ErrorStatus Enumeration


Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum ErrorStatus
Members
Member name Value Description
OK 0  
MakeMeProxy 1  
InvalidDrawing 2  
NotImplementedYet 3  
NotApplicable 4  
InvalidInput 5  
InvalidFiler 6  
AmbiguousInput 7  
AmbiguousOutput 8  
OutOfMemory 9  
NoInterface 10  
BufferTooSmall 11  
InvalidOpenState 12  
UnsupportedMethod 13  
EntityInInactiveLayout 14  
DuplicateHandle 15  
NullHandle 16  
BrokenHandle 17  
UnknownHandle 18  
HandleInUse 19  
NullObjectPointer 20  
NullObjectId 21  
NullBlockName 22  
ContainerNotEmpty 23  
NullEntityPointer 24  
IllegalEntityType 25  
KeyNotFound 26  
DuplicateKey 27  
InvalidIndex 28  
CharacterNotFound 29  
DuplicateIndex 30  
AlreadyInDB 31  
OutOfDisk 32  
DeletedEntry 33  
NegativeValueNotAllowed 34  
InvalidExtents 35  
InvalidAdsName 36  
InvalidSymbolTableName 37  
InvalidKey 38  
WrongObjectType 39  
WrongDatabase 40  
ObjectToBeDeleted 41  
InvalidFileVersion 42  
AnonymousEntry 43  
IllegalReplacement 44  
EndOfObject 45  
EndOfFile 46  
FileExists 47  
CantOpenFile 48  
FileCloseError 49  
FileWriteError 50  
NoFileName 51  
FilerError 52  
FileAccessErr 53  
FileSystemErr 54  
FileInternalErr 55  
FileTooManyOpen 56  
FileNotFound 57  
UnknownFileType 58  
IsReading 59  
IsWriting 60  
NotOpenForRead 61  
NotOpenForWrite 62  
NotThatKindOfClass 63  
InvalidBlockName 64  
MissingDxfField 65  
DuplicateDxfField 66  
InvalidDxfCode 67  
InvalidResultBuffer 68  
BadDxfSequence 69  
InvalidRoundTripR14Data 70  
VertexAfterFace 71  
InvalidVertexIndex 72  
OtherObjectsBusy 73  
MustFirstAddBlockToDB 74  
CannotNestBlockDefinitions 75  
DwgRecoveredOK 76  
DwgNotRecoverable 77  
DxfPartiallyRead 78  
DxfReadAborted 79  
DxbPartiallyRead 80  
DwgCRCError 81  
DwgSentinelDoesNotMatch 82  
DwgObjectImproperlyRead 83  
NoInputFiler 84  
DwgNeedsAFullSave 85  
DxbReadAborted 86  
DwkLockFileFound 87  
WasErased 88  
PermanentlyErased 89  
WasOpenForRead 90  
WasOpenForWrite 91  
WasOpenForUndo 92  
WasNotifying 93  
WasOpenForNotify 94  
OnLockedLayer 95  
MustOpenThruOwner 96  
SubentitiesStillOpen 97  
AtMaxReaders 98  
IsWriteProtected 99  
IsXRefObject 100  
NotAnEntity 101  
HadMultipleReaders 102  
InvalidBlkRecordName 103  
DuplicateRecordName 104  
NotXrefBlock 105  
EmptyRecordName 106  
XRefDependent 107  
SelfReference 108  
MissingSymbolTable 109  
MissingSymbolTableRecord 110  
WasNotOpenForWrite 111  
CloseWasNotifying 112  
CloseModifyAborted 113  
ClosePartialFailure 114  
CloseFailObjectDamaged 115  
CannotBeErasedByCaller 116  
CannotBeResurrected 117  
InsertAfter 118  
FixedAllErrors 119  
LeftErrorsUnfixed 120  
UnrecoverableErrors 121  
NoDatabase 122  
ExternalDataSizeExceeded 123  
CannotSaveHatchRoundtrip 124  
HatchHasInconsistentPatParams 125  
RegisteredApplicationIdNotFound 126  
RepeatEntity 127  
RecordNotInTable 128  
IteratorDone 129  
NullIterator 130  
NotInBlock 131  
OwnerNotInDatabase 132  
OwnerNotOpenForRead 133  
OwnerNotOpenForWrite 134  
ExplodeBeforeTransform 135  
CannotScaleNonOrtho 136  
CannotScaleNonUniformly 137  
NotInDatabase 138  
NotCurrentDatabase 139  
IsAnEntity 140  
CannotChangeActiveViewport 141  
NotInPaperspace 142  
CommandWasInProgress 143  
GeneralModelingFailure 144  
OutOfRange 145  
NonCoplanarGeometry 146  
DegenerateGeometry 147  
InvalidAxis 148  
PointNotOnEntity 149  
SingularPoint 150  
InvalidOffset 151  
NonPlanarEntity 152  
CannotExplodeEntity 153  
StringTooLong 154  
InvalidSymTableFlag 155  
UndefinedLineType 156  
InvalidTextStyle 157  
TooFewLineTypeElements 158  
TooManyLineTypeElements 159  
ExcessiveItemCount 160  
BadUcs 162  
BadPaperspaceView 163  
SomeInputDataLeftUnread 164  
NoInternalSpace 165  
InvalidDimStyle 166  
InvalidLayer 167  
InvalidMlineStyle 168  
DwgNeedsRecovery 169  
RecoveryFailed 170  
DeleteEntity 171  
InvalidFix 172  
BadLayerName 173  
LayerGroupCodeMissing 174  
BadColor 175  
BadColorIndex 176  
BadLinetypeName 177  
BadLinetypeScale 178  
BadVisibilityValue 179  
ProperClassSeparatorExpected 180  
BadLineWeightValue 181  
PagerError 182  
OutOfPagerMemory 183  
PagerWriteError 184  
WasNotForwarding 185  
InvalidIdMap 186  
InvalidOwnerObject 187  
OwnerNotSet 188  
WrongSubentityType 189  
TooManyVertices 190  
TooFewVertices 191  
NoActiveTransactions 192  
TransactionIsActive 193  
NotTopTransaction 194  
TransactionOpenWhileCommandEnded 195  
InProcessOfCommitting 196  
NotNewlyCreated 197  
LongTransReferenceError 198  
NoWorkSet 199  
AlreadyInGroup 200  
NotInGroup 201  
BadDwgFile 202  
InvalidInterfaceId 203  
InvalidNormal 204  
InvalidStyle 205  
CannotRestoreFromAcisFile 206  
eEmptyAcisFile 207  
NlsFileNotAvailable 208  
NotAllowedForThisProxy 209  
NotSupportedInDwgApi 210  
PolyWidthLost 211  
NullExtents 212  
ExplodeAgain 213  
BadDwgHeader 214  
LockViolation 215  
LockConflict 216  
DatabaseObjectsOpen 217  
LockChangeInProgress 218  
Vetoed 219  
NoDocument 220  
NotFromThisDocument 221  
LispActive 222  
TargetDocNotQuiescent 223  
DocumentSwitchDisabled 224  
InvalidContext 225  
CreateFailed 226  
CreateInvalidName 227  
SetFailed 228  
DelDoesNotExist 229  
DelIsModelSpace 230  
DelLastLayout 231  
DelUnableToSetCurrent 232  
DelUnableToFind 233  
RenameDoesNotExist 234  
RenameIsModelSpace 235  
RenameInvalidLayoutName 236  
RenameLayoutAlreadyExists 237  
RenameInvalidName 238  
CopyDoesNotExist 239  
CopyIsModelSpace 240  
CopyFailed 241  
CopyInvalidName 242  
CopyNameExists 243  
ProfileDoesNotExist 244  
InvalidProfileName 245  
ProfileIsInUse 246  
RegistryAccessError 247  
RegistryCreateError 248  
BadDxfFile 249  
UnknownDxfFileFormat 250  
MissingDxfSection 251  
InvalidDxfSectionName 252  
NotDxfHeaderGroupCode 253  
UndefinedDxfGroupCode 254  
NotInitializedYet 255  
InvalidDxf2dPoint 256  
InvalidDxf3dPoint 257  
BadlyNestedAppData 258  
IncompleteBlockDefinition 259  
IncompleteComplexObject 260  
BlockDefInEntitySection 261  
NoBlockBegin 262  
DuplicateLayerName 263  
BadPlotStyleName 264  
DuplicateBlockName 265  
BadPlotStyleType 266  
BadPlotStyleNameHandle 267  
UndefineShapeName 268  
DuplicateBlockDefinition 269  
MissingBlockName 270  
BinaryDataSizeExceeded 271  
ObjectIsReferenced 272  
InvalidThumbnailBitmap 273  
GuidNoAddress 275  
MustBe0to2 276  
MustBe0to3 277  
MustBe0to4 278  
MustBe0to5 279  
MustBe0to8 280  
MustBe1to8 281  
MustBe1to15 282  
MustBePositive 283  
MustBeNonNegative 284  
MustBeNonZero 285  
MustBe1to6 286  
NoPlotStyleTranslationTable 287  
PlotStyleInColorDependentMode 288  
MaxLayouts 289  
NoClassId 290  
UndoOperationNotAvailable 291  
UndoNoGroupBegin 292  
HatchTooDense 293  
OpenFileCancelled 294  
NotHandled 295  
LibIntegrityBroken 296  
AlreadyActive 297  
AlreadyInactive 298  
CodepageNotFound 299  
IncorrectInitFileVersion 300  
InternalFreetypeError 301  
NoUCSPresent 302  
BadObjType 303  
BadProtocolExtension 304  
HatchInvalidPatternName 305  
NotTransactionResident 306  
DwgFileIsEncrypted 307  
InvalidPassword 308  
DecryptionError 309  
ArithmeticOverflow 310  
SkipObjPaging 311  
StopPaging 312  
InvalidDimStyleResBufData 313  
ExtendedError 314  
GripOpFailure 315  
GripOpNoRedrawGrip 316  
GripOpGripHotToWarm 317  
GripOpGetNewGripPoints 318  
UnsupportedEarlyDwgVersion 319  
CannotChangeColumnType 320  
CustomSizeNotPossible 321  
DataLinkAdapterNotFound 322  
DataLinkInvalidAdapterId 323  
DataLinkNotFound 324  
DataLinkBadConnectionString 325  
DataLinkNotUpdatedYet 326  
DataLinkSourceNotFound 327  
DataLinkConnectionFailed 328  
DataLinkSourceIsWriteProtected 330  
DataLinkOtherError 332  
DeviceNotFound 333  
DwgCrcDoesNotMatch 334  
DwgShareDemandLoad 335  
DwgShareReadAccess 336  
DwgShareWriteAccess 337  
FileMissingSections 338  
FileSharingViolation 339  
FiniteStateMachineError 340  
GraphicsNotGenerated 341  
HandleExists 342  
IgnoredLinetypeRedefinition 343  
IncompatiblePlotSettings 344  
InternetBadPath 345  
InternetBase 346  
InternetCreateInternetSessionFailed 347  
InternetDirectoryFull 348  
InternetDiskFull 349  
InternetFileAccessDenied 350  
InternetFileGenericError 351  
InternetFileNotFound 352  
InternetFileOpenFailed 353  
InternetGenericException 354  
InternetHardwareError 355  
InternetHttpAccessDenied 356  
InternetHttpBadGateway 357  
InternetHttpBadMethod 358  
InternetHttpBadRequest 359  
InternetHttpConflict 360  
InternetHttpGatewayTimeout 361  
InternetHttpLengthRequired 362  
InternetHttpNoAcceptableResponse 363  
InternetHttpNotSupported 364  
InternetHttpObjectNotFound 365  
InternetHttpOpenRequestFailed 366  
InternetHttpPaymentRequired 367  
InternetHttpPreconditionFailure 368  
InternetHttpProxyAuthorizationRequired 369  
InternetHttpRequestForbidden 370  
InternetHttpRequestTooLarge 371  
InternetHttpResourceGone 372  
InternetHttpServerError 373  
InternetHttpServiceUnavailable 374  
InternetHttpTimedOut 375  
InternetHttpUnsupportedMedia 376  
InternetHttpUriTooLong 377  
InternetHttpVersionNotSupported 378  
InternetInCache 379  
InternetInternetError 380  
InternetInternetSessionConnectFailed 381  
InternetInternetSessionOpenFailed 382  
InternetInvalidAccessType 383  
InternetInvalidFileHandle 384  
InternetNoInternetSupport 385  
InternetNotAnUrl 386  
InternetNotImplemented 387  
InternetNoWinInternet 388  
InternetOK 389  
InternetOldWinInternet 390  
InternetProtocolNotSupported 391  
InternetSharingViolation 392  
InternetTooManyOpenFiles 393  
InternetUnknownError 394  
InternetUserCancelledTransfer 395  
InternetValidUrl 396  
InvalidEngineState 397  
InvalidFaceVertexIndex 398  
InvalidFileExtension 399  
InvalidMeshVertexIndex 400  
InvalidObjectId 401  
InvalidPlotArea 402  
InvalidPlotInfo 403  
InvalidView 404  
InvalidWindowArea 405  
InvalidXrefObjectId 406  
LayoutNotCurrent 407  
MakeMeProxyAndResurrect 408  
MustPlotToFile 409  
CannotPlotToFile 410  
NoCurrentConfig 411  
NoErrorHandler 412  
NoLabelBlock 413  
NoLayout 414  
NoMatchingMedia 415  
NonePlotDevice 416  
NoThumbnailBitmap 417  
NotMultiPageCapable 418  
NoViewAssociation 419  
NullPtr 420  
NumberOfCopiesNotSupported 421  
ObsoleteFileFormat 422  
PageCancelled 423  
PlotAlreadyStarted 424  
PlotCancelled 425  
RepeatedDwgRead 426  
RowsMustMatchColumns 427  
SecErrorCipherNotSupported 428  
SecErrorComputingSignature 429  
SecErrorDecryptingData 430  
SecErrorEncryptingData 431  
SecErrorGeneratingTimestamp 432  
SecErrorReadingFile 433  
SecErrorWritingFile 434  
SecErrorWritingSignature 435  
SecInitializationFailure 436  
SecInvalidDigitalId 437  
LoadFailed 438  
SubSelectionSetEmpty 439  
UnableToGetLabelBlock 440  
UnableToGetViewAssociation 441  
UnableToRemoveAssociation 442  
UnableToSetLabelBlock 443  
UnableToSetViewAssociation 444  
UnableToSyncModelView 445  
UnsupportedFileFormat 446  
UserBreak 447  
WasNotErased 448  
WrongCellType 449  
TxError 450  
HiddenLayerNotAllowed 451  
InvalidLicense 452  
IncorrectDatabaseType 453  
InvalidCategory 454  
CryptProviderUnavailable 455  
InvalidNumPCurves 456  
NoTrimmigLoop 457  
BrokenTrimmingLoop 458  
BadApexLoop 459  
LoopNotClosed 460  
LoopIsNotOnFace 461  
LoopSelfIntersecting 462  
InvalidIntervals 463  
EmptySet 464  
Infinite 465  
DataTooLarge 466  
SyntaxError 467  
DisabledInConfig 468  
CantSetEnvVar 469  
InvalidSurface 470  
InvalidOrientation 471  
LoopsIntersecting 472  
InvalidEdge 473  
NullEdgeCurve 474  
NullFaceSurface 475  
StartOrEndPntNotSet 476  
IntervalIsTooShort 477  
CurveLengthIsTooShort 478  
CurveEndsMissed 479  
PointNotOnCurve 480  
InvalidProps 481  
InvalidCurve 482  
DiscontinuousCurve 483  
ParamHasNoValue 484  
BrFileMissed 485  
BrBrepMissed 486  
BrComplexMissed 487  
BrShellMissed 488  
BrFaceMissed 489  
BrLoopMissed 490  
BrEdgeMissed 491  
BrVertexMissed 492  
BrEmptyLoop 493  
CellNotFound 494  
InvalidElementState 495  
NoIntersections 496  
MSmemcpySecureInvalidParameter 497  
MSmemmoveSecureInvalidParameter 498  
DaiInternalError 499  
ODANotActivated 999,999  
See Also

©  Bricsys NV. All rights reserved.