GridLineType Enumeration

This enum class represents grid linetypes.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public enum GridLineType
Members
Member name Value Description
InvalidGridLine 0 Invalid grid linetype.
HorizontalTop 1 Top or bottom horizontal table's grid line, depending on the flow direction of the table rows.
HorizontalInside 2 All horizontal grid lines, excluding the bottom and top lines.
HorizontalBottom 4 Bottom or top horizontal table's grid line, depending on the flow direction of the table rows.
HorizontalGridLines 7 All horizontal grid linetypes.
VerticalLeft 8 The grid line at the left of the table.
VerticalInside 16 All vertical grid lines, excluding the left and right lines.
InnerGridLines 18 Inner grid line types.
VerticalRight 32 The grid line at the right of the table.
OuterGridLines 45 Outer grid linetypes.
VerticalGridLines 56 Vertical grid linetypes.
AllGridLines 63 All grid linetypes
See Also

©  Bricsys NV. All rights reserved.