GeometricalConstraintConstraintType Enumeration

Indicate the new constraint type when it is added between geometries.

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public enum ConstraintType
Members
Member name Value Description
Horizontal 0 Horizontal constraint applied to a line or two points.
Vertical 1 Vertical constraint applied to a line or two points.
Parallel 2 Parallel constraint applied between two lines.
Perpendicular 3 Perpendicular constraint applied between two lines.
Normal 4 Normal constraint applied between a line and circle (or arc).
Collinear 5 Collinear constraint applied between two lines.
Coincident 6 Coincident constraint applied between point and point or point and curve.
Concentric 7 Concentric constraint applied between any two of circles, ellipses, or arcs.
Tangent 8 Tangent constraint applied between two curves (except two lines).
EqualRadius 9 Equal radius constraint applied between any two of circles or arcs.
EqualLength 10 Equal length constraint applied between two bounded lines (not rays).
Symmetric 11 Symmetric constraint applied between two of same geometry types.
Smooth 12 Smooth constraint applied between a bounded spline and a bounded curve.
Fix 13 Fix constraint applied on any supported geometry.
See Also

©  Bricsys NV. All rights reserved.