TextStyle(String, String, Double, Double, Double, Double, Boolean, Boolean, Boolean, Boolean, Boolean, String) Constructor

Constructor for the TextStyle class. Constructs a text style with the specified properties.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public TextStyle(
        string fontName,
        string bigFontName,
        double textSize,
        double x,
        double obliqueAngle,
        double trackingPercent,
        bool isBackward,
        bool isUpsideDown,
        bool isVertical,
        bool isOverLined,
        bool isUnderlined,
        string styleName
)

Parameters

fontName  String
[in] Font filename.
bigFontName  String
[in] BigFont filename.
textSize  Double
[in] Fixed text size.
x  Double
[in] X-scale (width) factor of text.
obliqueAngle  Double
[in] Obliquing angle of text in the range of [-1.48335 .. +1.48335] radians or [-85°.. +85°]. Oblique angle is expressed in radians.
trackingPercent  Double
[in] Tracking percent of text.
isBackward  Boolean
[in] Controls backwards drawing of text.
isUpsideDown  Boolean
[in] Controls upside down drawing of text.
isVertical  Boolean
[in] Controls vertical drawing of text.
isOverLined  Boolean
[in] Controls overlined drawing of text.
isUnderlined  Boolean
[in] Controls underlined drawing of text.
styleName  String
[in] Name of the text style to assign.
See Also

©  Bricsys NV. All rights reserved.