TextStyle Class

This class provides an interface to the display attributes of text.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceTextStyle

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class TextStyle : RXObject

The TextStyle type exposes the following members.

Constructors
  Name Description
Public method TextStyle Default constructor for the TextStyle class.
Public method TextStyle(String, String, Double, Double, Double, Double, Boolean, Boolean, Boolean, Boolean, Boolean, String) Constructor for the TextStyle class. Constructs a text style with the specified properties.
Top
Properties
  Name Description
Public property Backward Property that indicates whether text is drawn backwards with this Text Style.
Public property BigFontFileName Property that represents the BigFont filename for this TextStyle.
Public property FileName Property that represents a full path to the font file for this text style.
Public property Font Property that represents the font associated with this TextStyle.
Public property LoadStyleRec  
Public property ObliquingAngle Property that represents the obliquing angle of text. ObliquingAngle has a domain of ±1.48335 radians (±85°). Negative angles will have Oda2PI added to them.
Public property Overlined Property that indicates whether the text is overlined.
Public property PreLoaded Property that indicates whether this TextStyle has a pre-loaded font.
Public property StyleName Property that represents the style name for this TextStyle.
Public property TextSize Property that represents the fixed text size for this TextStyle.
Public property TrackingPercent Property that represents the tracking percent for this TextStyle.
Public property Underlined Property that indicates whether text is drawn underlined with this TextStyle.
Public property UpsideDown Property that indicates whether text is drawn upside down with this TextStyle.
Public property Vertical Property that indicates whether text is drawn vertical with this TextStyle.
Public property XScale Property that represents the X-scale (width) factor for this TextStyle.
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method ExtentsBox Calculates the extents of the specified text string when using this text style. Currently not implemented.
Public method FromTextStyleTableRecord(ObjectId) Copies a text style from the TextStyleTableRecord represented by the passed styleId.
Public method FromTextStyleTableRecord(String) Copies a text style from the TextStyleTableRecord represented by the passed styleName.
Public method SetTrackKerning Sets the tracking percent for this text style. Tracking percent is a multiplier for the spacing between characters as defined in the font file.
Top
See Also

©  Bricsys NV. All rights reserved.