NurbSurfaceInsertKnotAtV Method
|
Inserts a knot at the specified v parameter.
The knot insertion doesn't modify the shape of the surface. It adds
a new row of control points in the u-direction and adjusts the
local control point's location.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void InsertKnotAtV(
double dV
)
Public Sub InsertKnotAtV (
dV As Double
)
public:
void InsertKnotAtV(
double dV
)
member InsertKnotAtV :
dV : float -> unit
Parameters
- dV Double
- [in] V parameter.
Remarks
If the surface
doesn't contain any NURBS information, the method throws the
eFail exception. If the surface's knot
multiplicity at the v parameter is bigger than the degree in the
v-direction, throws the eInvalidInput
exception. If this method is not implemented for a specific
modeler, throws the eNotImplementedYet
exception.
See Also