SubDMeshSetCylinder
Method
|
Creates a mesh of a cylinder.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetCylinder(
double majorRadius,
double minorRadius,
double height,
int divAxis,
int divHeight,
int divCap,
int smoothLevel
)
Public Sub SetCylinder (
majorRadius As Double,
minorRadius As Double,
height As Double,
divAxis As Integer,
divHeight As Integer,
divCap As Integer,
smoothLevel As Integer
)
public:
void SetCylinder(
double majorRadius,
double minorRadius,
double height,
int divAxis,
int divHeight,
int divCap,
int smoothLevel
)
member SetCylinder :
majorRadius : float *
minorRadius : float *
height : float *
divAxis : int *
divHeight : int *
divCap : int *
smoothLevel : int -> unit
Parameters
- majorRadius Double
- [in] Major radius.
- minorRadius Double
- [in] Minor radius.
- height Double
- [in] Height of a cylinder.
- divAxis Int32
- [in] Specifies how many divisions are made for the base
circle.
- divHeight Int32
- [in] Specifies how many divisions are made in the direction of
the height of a cylinder.
- divCap Int32
- [in] Specifies how many radial divisions are made for the base
circle.
- smoothLevel Int32
- [in] Level of smoothness.
See Also