AugmentedPolylineCurve3d Constructor

Overload List
  Name Description
Public method AugmentedPolylineCurve3d Default constructor for the AugmentedPolylineCurve3d class. Creates an object with no valid data assigned.
Public method AugmentedPolylineCurve3d(Point3dCollection, Vector3dCollection) Constructor for the AugmentedPolylineCurve3d class. Constructs a 3D polyline with vectors corresponding to each control point.
Public method AugmentedPolylineCurve3d(KnotCollection, Point3dCollection, Vector3dCollection) Constructor for the AugmentedPolylineCurve3d class. Constructs an object with knots, control points, and vectors.
Public method AugmentedPolylineCurve3d(Curve3d, Double, Double, Double) Constructor for the AugmentedPolylineCurve3d class. Constructs a polyline that approximates the passed curve of the specified parametric range with the specified precision.
Top
See Also