AugmentedPolylineCurve3d(KnotCollection,
Point3dCollection, Vector3dCollection)
Constructor
|
Constructor for the AugmentedPolylineCurve3d
class. Constructs an object with knots, control points, and
vectors.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public AugmentedPolylineCurve3d(
KnotCollection knots,
Point3dCollection controlPoints,
Vector3dCollection vectorBundle
)
Public Sub New (
knots As KnotCollection,
controlPoints As Point3dCollection,
vectorBundle As Vector3dCollection
)
public:
AugmentedPolylineCurve3d(
KnotCollection^ knots,
Point3dCollection^ controlPoints,
Vector3dCollection^ vectorBundle
)
new :
knots : KnotCollection *
controlPoints : Point3dCollection *
vectorBundle : Vector3dCollection -> AugmentedPolylineCurve3d
Parameters
- knots KnotCollection
- [in] Array of knots.
- controlPoints Point3dCollection
- [in] Array of 3D control points.
- vectorBundle Vector3dCollection
- [in] Array of 3D vectors.
See Also