LinkedTableDataSetBlockAttributeValue
Method
|
Sets the attribute value of the block cell
using the specified object ID key.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetBlockAttributeValue(
int row,
int column,
ObjectId attributeDefinitionId,
string value
)
Public Overridable Sub SetBlockAttributeValue (
row As Integer,
column As Integer,
attributeDefinitionId As ObjectId,
value As String
)
public:
virtual void SetBlockAttributeValue(
int row,
int column,
ObjectId attributeDefinitionId,
String^ value
)
abstract SetBlockAttributeValue :
row : int *
column : int *
attributeDefinitionId : ObjectId *
value : string -> unit
override SetBlockAttributeValue :
row : int *
column : int *
attributeDefinitionId : ObjectId *
value : string -> unit
Parameters
- row Int32
- [in] Row index of the cell.
- column Int32
- [in] Column index of the cell.
- attributeDefinitionId ObjectId
- [in] Object ID of the attribute definition.
- value String
- [in] Attribute value.
Remarks
The method
generates the eInvalidInput exception
when the input row number and column number are less than 0 or
greater than the table size. The method also generates the
eIsWriteProtected exception when content
is not editable.
See Also