SplineToPolyline(UInt32, Boolean,
Boolean) Method
|
Generates a polyline to approximate a
spline.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Curve ToPolyline(
uint numOfVertices,
bool bConvertAsArcs,
bool bToLWPolyline
)
Public Function ToPolyline (
numOfVertices As UInteger,
bConvertAsArcs As Boolean,
bToLWPolyline As Boolean
) As Curve
public:
Curve^ ToPolyline(
unsigned int numOfVertices,
bool bConvertAsArcs,
bool bToLWPolyline
)
member ToPolyline :
numOfVertices : uint32 *
bConvertAsArcs : bool *
bToLWPolyline : bool -> Curve
Parameters
- numOfVertices UInt32
- [in] Vertices threshold value. The resulting polyline's vertex
count does not exceed this value.
- bConvertAsArcs Boolean
- [in] Flag that specifies whether to convert to arcs when the
spline is planar.
- bToLWPolyline Boolean
- [in] Flag that specifies whether to convert to a polyline when
the spline is planar.
Return Value
Curve
Polyline from this spline.
Remarks
The resulting
curve can be a Polyline, Polyline2d, or Polyline3d type. If at
least one of the points of the spline does not lie on the XY plane,
a Polyline3d is created from linear segments. If bConvertAsArcs is
true and the spline is flat, the resulting polyline is a segment of
the arc, otherwise it is line segments. And, if the spline is flat
and bToLWPolyline is true, the result is Polyline, otherwise it is
Polyline2d.
See Also