Sets (replaces) row data at the specified row
index.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetRowAt(
int index,
DataCellCollection row,
bool validate
)
Public Overridable Sub SetRowAt (
index As Integer,
row As DataCellCollection,
validate As Boolean
)
public:
virtual void SetRowAt(
int index,
DataCellCollection^ row,
bool validate
)
abstract SetRowAt :
index : int *
row : DataCellCollection *
validate : bool -> unit
override SetRowAt :
index : int *
row : DataCellCollection *
validate : bool -> unit
Parameters
- index Int32
- [in] Row index.
- row DataCellCollection
- [in] Collection of cells for a row.
- validate Boolean
- [in] Validation flag.
Remarks
The validate parameter specifies whether to perform
validation when adding a row. If validate
is true, this method validates the type
of each cell against the type of each corresponding column and
validates the number of columns in a row against the number of
columns in this data table.
See Also