LinkedTableDataSetDataType Method
|
Sets the data type of the first content of a
cell.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetDataType(
int row,
int column,
DataType dataType,
UnitType unitType
)
Public Overridable Sub SetDataType (
row As Integer,
column As Integer,
dataType As DataType,
unitType As UnitType
)
public:
virtual void SetDataType(
int row,
int column,
DataType dataType,
UnitType unitType
)
abstract SetDataType :
row : int *
column : int *
dataType : DataType *
unitType : UnitType -> unit
override SetDataType :
row : int *
column : int *
dataType : DataType *
unitType : UnitType -> unit
Parameters
- row Int32
- [in] Row index of the cell.
- column Int32
- [in] Column index of the cell.
- dataType DataType
- [in] Data type.
- unitType UnitType
- [in] Unit type.
Remarks
The method
generates the eInvalidInput exception
when the input row number and column number are less than 0 or
greater than the table size. The method generates the eIsWriteProtected exception when content is not
editable. Unit type can take one of the following values:
NameValueUnitless 0x00 Distance 0x01 Angle 0x02 Area 0x04
Volume 0x08 Currency 0x10 Percentage 0x20 Data type that can have
one of the following values: NameValueUnknown 0x00 Long
0x01 Double 0x02 String 0x04 Date 0x08 Point 0x10 Point3d 0x20
ObjectId 0x40 Buffer 0x80 Resbuf 0x100 General 0x200
See Also