ProxyObjectProxyFlags
Property
|
Property that represents the edit flags for
the class associated with this proxy object. These bit flags
determine the allowable operations on this proxy object. This
property is a combination of one or more of the following: Name
Value Description kNoOperation 0x0 None kEraseAllowed 0x1 erase()
kCloningAllowed 0x80 subDeepClone(), subWblockClone()
kAllButCloningAllowed 0x1 erase() kAllAllowedBits 0x81 erase(),
subDeepClone(), subWblockClone() kMergeIgnore 0x00 Keep orignal
names. kMergeReplace 0x100 Use clone. kMergeMangleName 0x200 Create
anonymous names.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public int ProxyFlags { get; }
Public ReadOnly Property ProxyFlags As Integer
Get
public:
property int ProxyFlags {
int get ();
}
member ProxyFlags : int with get
Property Value
Int32
See Also