SectionSettingsGenerationOptions Method
|
Returns the current generation options for the
specified section type.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public SectionGeneration GenerationOptions(
SectionType nSecType
)
Public Function GenerationOptions (
nSecType As SectionType
) As SectionGeneration
public:
SectionGeneration GenerationOptions(
SectionType nSecType
)
member GenerationOptions :
nSecType : SectionType -> SectionGeneration
Parameters
- nSecType SectionType
- [in] Section type.
Return Value
SectionGeneration
One of the following enumeration values representing the current
generation options: SourceAllObjects - Section plane cuts through
all objects. SourceSelectedObjects - Section plane cuts only
through selected objects. DestinationNewBlock - Section is created
as a new block. DestinationReplaceBlock - Section replaces an
existing block. DestinationFile - Section is saved in a file.
See Also