NonEntityTraitsAddLight
Method
|
Drawables that emit light can add one or more
lights to the model. Through this interface, light position,
intensity and other properties are sent to the graphics system.
Default implementation of this method throws the
NotSupportedException exception.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public override sealed void AddLight(
ObjectId lightId
)
Public Overrides NotOverridable Sub AddLight (
lightId As ObjectId
)
public:
virtual void AddLight(
ObjectId lightId
) override sealed
abstract AddLight :
lightId : ObjectId -> unit
override AddLight :
lightId : ObjectId -> unit
Parameters
- lightId ObjectId
-
See Also