NonEntityTraits Class

This class implements empty interfaces to allow non-entity drawables to provide their unique properties through DrawableTraits.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceNonEntityTraits
              More

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class NonEntityTraits : SubEntityTraits

The NonEntityTraits type exposes the following members.

Constructors
  Name Description
Protected method NonEntityTraits Initializes a new instance of the NonEntityTraits class
Top
Properties
Methods
  Name Description
Public method AddLight Drawables that emit light can add one or more lights to the model. Through this interface, light position, intensity and other properties are sent to the graphics system. Default implementation of this method throws the NotSupportedException exception.
(Overrides DrawableTraitsAddLight(ObjectId))
Protected method SetLayerFlags
(Overrides DrawableTraitsSetLayerFlags(DrawableTraitsLayerFlags))
Public method SetSelectionMarker Sets the SubEntityTraits object to use the specified graphics marker for all graphics primitives drawn until the next call to this function, or the end of WorldDraw() or ViewportDraw() execution. Default implementation of this method throws the NotSupportedException exception.
(Overrides SubEntityTraitsSetSelectionMarker(IntPtr))
Public method SetupForEntity Initializes all subentity traits and drawable traits from the entity. This can be more convenient than setting each property individually. Default implementation of this method throws the NotSupportedException exception.
(Overrides DrawableTraitsSetupForEntity(Entity))
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawableTraits
          Teigha.GraphicsInterfaceSubEntityTraits
            Teigha.GraphicsInterfaceNonEntityTraits
              Teigha.GraphicsInterfaceGradientBackgroundTraits
              Teigha.GraphicsInterfaceGroundPlaneBackgroundTraits
              Teigha.GraphicsInterfaceImageBackgroundTraits
              Teigha.GraphicsInterfaceLightTraits
              Teigha.GraphicsInterfaceRenderSettingsTraits

©  Bricsys NV. All rights reserved.