SubDMeshConvertToSolid Method
|
Creates a new 3D solid object from this
mesh.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Solid3d ConvertToSolid(
bool convertAsSmooth,
bool optimize
)
Public Function ConvertToSolid (
convertAsSmooth As Boolean,
optimize As Boolean
) As Solid3d
public:
Solid3d^ ConvertToSolid(
bool convertAsSmooth,
bool optimize
)
member ConvertToSolid :
convertAsSmooth : bool *
optimize : bool -> Solid3d
Parameters
- convertAsSmooth Boolean
- [in] Flag that specifies whether to convert to a smooth
surface. If false, converts to a faceted surface.
- optimize Boolean
- [in] Flag that specifies whether to convert as an optimized
surface.
Return Value
Solid3d
Solid3d object converted from this SubDMesh.
See Also