Solid3dBooleanOperation Method

Performs a Boolean operation between this solid and another solid object.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void BooleanOperation(
        BooleanOperationType operation,
        Solid3d solid
)

Parameters

operation  BooleanOperationType
[in] Type of Boolean operation.
solid  Solid3d
[in] Other solid object.
Remarks
Possible Boolean operations: * BoolUnite - unites two solids into one. * BoolIntersect - returns the intersection of two solids. * BoolSubtract - subtracts the specified solid from this one.
See Also

©  Bricsys NV. All rights reserved.