Scale2dRemoveScale
Method
|
Returns the scale vector corresponding to the
length of the column vectors of the transformation matrix, and sets
the scale factor of the matrix to 1.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static Scale2d RemoveScale(
Matrix2d mat
)
Public Shared Function RemoveScale (
mat As Matrix2d
) As Scale2d
public:
static Scale2d RemoveScale(
Matrix2d mat
)
static member RemoveScale :
mat : Matrix2d -> Scale2d
Parameters
- mat Matrix2d
- [in/out] Transformation matrix to modify.
Return Value
Scale2d
See Also