DimAssocPointType Enumeration
|
Represents the type of point
association.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum DimAssocPointType
Public Enumeration DimAssocPointType
public enum class DimAssocPointType
Members
Member name |
Value |
Description |
Xline1Point |
0 |
First extension line point. |
OriginPoint |
0 |
Origin point. |
Xline1Start |
0 |
First extension line start point. |
ChordPoint |
0 |
Chord point. |
LeaderPoint |
0 |
Leader point. |
Xline2Point |
1 |
Second extension line point. |
DefiningPoint |
1 |
Dimension defining point. |
Xline1End |
1 |
First extension line end point. |
CenterPoint |
1 |
Center point. |
FarChordPoint |
1 |
Far chord point. |
Xline2Start |
2 |
Second extension line start point. |
VertexPoint |
2 |
Vertex point. |
OverrideCenterPoint |
2 |
Override center point. |
AngLineStart |
2 |
Angle start point. |
Xline2End |
3 |
Second extension line end point. |
JogPoint |
3 |
Jog point. |
AngLineEnd |
3 |
Angle end point. |
See Also