This enumeration provides the mode values used
to specify how a database resident object is to be opened.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
Public Enumeration FileOpenMode
public enum class FileOpenMode
Members
Member name |
Value |
Description |
OpenForReadAndReadShare |
1 |
Open for reading and allow read sharing. When used in
Database.ReadDwgFile(), other applications cannot write to the
file. Also, if the file was already opened by another application
for writing, Database.ReadDwgFile() will fail. |
OpenForReadAndWriteNoShare |
2 |
Open for reading and writing and allow no sharing. When used in
Database.ReadDwgFile(), other applications cannot perform read and
write operations on the file. A Database.ReadDwgFile call using
this mode fails if any other application has the drawing file open
or if the drawing file is read-only. |
OpenForReadAndAllShare |
3 |
Open for reading and allow read and write sharing. When used in
Database.ReadDwgFile(), other applications have full access to the
file. This call opens a file for reading when the same file is
already opened for writing. This mode in the Database.ReadDwgFile()
call does not block other applications from writing to the opened
file. |
OpenTryForReadShare |
4 |
Causes the database to initially open the file using
ForReadAndReadShare, and if the attempt is not successful, tries
opening with the ForReadAndAllShare option. |
See Also