NurbSurfaceDefinitionInequality Operator

Inequality operator for the NurbSurfaceDefinition structure. Checks whether NURBS surface definitions are not equal.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public static bool operator !=(
        NurbSurfaceDefinition a,
        NurbSurfaceDefinition b
)

Parameters

a  NurbSurfaceDefinition
[in] Left curve fit data to compare.
b  NurbSurfaceDefinition
[in] Right curve fit data to compare.

Return Value

Boolean
true if at least one of the following conditions fails: * Degrees in U are equal, and degrees in V are equal. * Properties in U are equal, and properties in V are equal. * Count of control points in U are equal, and count of control points in V are equal. * Control points are equal. * Weight values are equal. * Knots in U are equal, and knots in V are equal.
See Also

©  Bricsys NV. All rights reserved.