NurbSurfaceDefinition Structure

This structure stores data that can be accessed with the NurbSurface.GetDefinition method. For more information, see Working with NURBS Surfaces.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryNurbSurfaceDefinition

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct NurbSurfaceDefinition

The NurbSurfaceDefinition type exposes the following members.

Properties
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo Checks whether this NURBS surface definition is equal to the passed NURBS surface definition.
Top
Operators
  Name Description
Public operatorStatic member Equality(NurbSurfaceDefinition, NurbSurfaceDefinition) Equality operator for the NurbSurfaceDefinition structure. Checks whether NURBS surface definitions are equal.
Public operatorStatic member Inequality(NurbSurfaceDefinition, NurbSurfaceDefinition) Inequality operator for the NurbSurfaceDefinition structure. Checks whether NURBS surface definitions are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.