AssocActionSetStatus
Method
|
Sets the status for this action.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public void SetStatus(
AssocStatus newStatus,
bool notifyOwningNetwork,
bool setInOwnedActions
)
Public Sub SetStatus (
newStatus As AssocStatus,
notifyOwningNetwork As Boolean,
setInOwnedActions As Boolean
)
public:
void SetStatus(
AssocStatus newStatus,
bool notifyOwningNetwork,
bool setInOwnedActions
)
member SetStatus :
newStatus : AssocStatus *
notifyOwningNetwork : bool *
setInOwnedActions : bool -> unit
Parameters
- newStatus AssocStatus
- [in] New status for this action.
- notifyOwningNetwork Boolean
- [in] Flag that specifies whether to mark this action as
needed for evaluation and set the same
status for the owning network (if possible).
- setInOwnedActions Boolean
- [in] Flag that specifies whether to set the same status for all
owned actions (if they exist).
See Also