GIRasterImageConvert(Boolean,
Double, Double) Method
|
Converts this raster image according to the
specified parameters and returns a handle to the converted
image.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public GIRasterImage Convert(
bool convertPaletteToRGB,
double brightness,
double contrast
)
Public Function Convert (
convertPaletteToRGB As Boolean,
brightness As Double,
contrast As Double
) As GIRasterImage
public:
GIRasterImage^ Convert(
bool convertPaletteToRGB,
double brightness,
double contrast
)
member Convert :
convertPaletteToRGB : bool *
brightness : float *
contrast : float -> GIRasterImage
Parameters
- convertPaletteToRGB Boolean
- [in] Color is converted to RGB if true.
- brightness Double
- [in] Image brightness [0 .. 100].
- contrast Double
- [in] Image contrast [0 .. 100].
Return Value
GIRasterImage
See Also