Writes a Stereo Lithography (STL)
representation of the solid to a file with the specified
name.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void StlOut(
string fileName,
bool asciiFormat
)
Public Overridable Sub StlOut (
fileName As String,
asciiFormat As Boolean
)
public:
virtual void StlOut(
String^ fileName,
bool asciiFormat
)
abstract StlOut :
fileName : string *
asciiFormat : bool -> unit
override StlOut :
fileName : string *
asciiFormat : bool -> unit
Parameters
- fileName String
- [in] File name.
- asciiFormat Boolean
- [in] Flag determining the format of the output file (true -
ASCII text format, false - binary format).
Remarks
If the specified
file already exists, it is overwritten. If at least one of the
obtained triangle points has at least one coordinate from the
(-inf, 0] interval, all points are shifted to an octant, where all
coordinates are positive numbers from the [0.01, +inf)
interval.
See Also