NurbCurve3dSetFitData(Int32,
Point3dCollection) Method
|
Sets the fit data for this spline.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetFitData(
int degree,
Point3dCollection fitPoints
)
Public Sub SetFitData (
degree As Integer,
fitPoints As Point3dCollection
)
public:
void SetFitData(
int degree,
Point3dCollection^ fitPoints
)
member SetFitData :
degree : int *
fitPoints : Point3dCollection -> unit
Parameters
- degree Int32
- [in] Degree of the curve.
- fitPoints Point3dCollection
- [in] Interpolation points.
Remarks
Recomputes the
spline from the input fit points and makes it of the specified
degree. High degree values make the curve more flexible. For
example, degree of 1 is used to define a polyline, and degree of 2
is used to define a NURBS circle, etc.
See Also