Solid3dSlice(Surface,
Boolean) Method
|
Slices the solid with a surface and transforms
the native solid to be the portion remaining on the positive side
of the slicing surface normal.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Solid3d Slice(
Surface surface,
bool negativeHalfToo
)
Public Overridable Function Slice (
surface As Surface,
negativeHalfToo As Boolean
) As Solid3d
public:
virtual Solid3d^ Slice(
Surface^ surface,
bool negativeHalfToo
)
abstract Slice :
surface : Surface *
negativeHalfToo : bool -> Solid3d
override Slice :
surface : Surface *
negativeHalfToo : bool -> Solid3d
Parameters
- surface Surface
- [in] Slicing surface.
- negativeHalfToo Boolean
- [in] Flag determining whether the other (negative) part of the
native solid should be created as a separate solid.
Return Value
Solid3d
Created solid representing the negative half of the native
solid.
Remarks
This method is
implemented only for the Spatial modeler.
See Also