This enum class represents cell states.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
Public Enumeration CellStates
public enum class CellStates
Members
Member name |
Value |
Description |
None |
0 |
No defined state. |
ContentLocked |
1 |
Cell's content is locked. |
ContentReadOnly |
2 |
Cell's content is read-only. |
Linked |
4 |
Cell is linked to a data source. |
ContentModifiedAfterUpdate |
8 |
Cell's content has been modified since last update. |
FormatLocked |
16 |
Cell's format is locked. Can be unlocked by user. |
FormatReadOnly |
32 |
Cell's format is read-only. |
FormatModifiedAfterUpdate |
64 |
Cell's format has been modified since last update. |
See Also