Polyline Class

This class implements the equivalent of OdDbPolyline or a lightweight polyline. Instances of this class are used to pass lightweight polyline data through the ODA Platform vectorization framework.
Inheritance Hierarchy
SystemObject
  Teigha.GraphicsInterfacePolyline

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class Polyline

The Polyline type exposes the following members.

Constructors
  Name Description
Public method Polyline Default constructor for the Polyline class. Creates an empty polyline.
Public method Polyline(Point3dCollection, Vector3d, IntPtr) Constructor for the Polyline class. Creates a polyline from a subentity marker, collection of points, and normal to the plane where this polyline lies.
Top
Properties
  Name Description
Public property BaseSubEntMarker  
Public property Normal  
Public property Points  
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.