NurbSurfaceGetWeight Method

Returns the weight at the specified position (defined by the iUIndex and iVIndex parameters) in the weights array. Returns a valid weight value only when the surface is rational.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public double GetWeight(
        int iUIndex,
        int iVIndex
)

Parameters

iUIndex  Int32
[in] An index of the weight value in the u-direction. Index starts from the 0 value.
iVIndex  Int32
[in] An index of the weight value in the v-direction. Index starts from the 0 value.

Return Value

Double
Remarks
If the surface doesn't contain weight information, the method throws the eFail exception. If the iUIndex or iVIndex values are invalid, throws the eOutOfRange exception.
See Also

©  Bricsys NV. All rights reserved.