Represents the pixel organization scheme of
the source image file.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
Public Enumeration ImageOrg
public enum class ImageOrg
Members
Member name |
Value |
Description |
Bitonal |
0 |
Binary (1 bit per pixel). |
Palette |
1 |
8 bits per pixel, colors are stored in a palette. Image pixels
have palette indices instead of colors directly. |
Gray |
2 |
8 bits per pixel gray scale (0 = black, 255 = white). |
RGBA |
3 |
32 bits per pixel, red-green-blue-alpha. |
BGRA |
4 |
32 bits per pixel, blue-green-red-alpha. |
ARGB |
5 |
32 bits per pixel, alpha-red-green-blue. |
ABGR |
6 |
32 bits per pixel, alpha-blue-green-red. |
BGR |
7 |
24 bits per pixel, blue-green-red. |
RGB |
8 |
24 bits per pixel, red-green-blue. |
See Also