AcadSectionClassGenerateSectionGeometry
Method
|
Namespace: BricscadDb
Assembly: Interop.BricscadDb (in
Interop.BricscadDb.dll) Version: 24.0.0.0
Syntax
public virtual void GenerateSectionGeometry(
AcadEntity pEntity,
out Object pIntersectionBoundaryObjs,
out Object pIntersectionFillObjs,
out Object pBackgroudnObjs,
out Object pForegroudObjs,
out Object pCurveTangencyObjs
)
Public Overridable Sub GenerateSectionGeometry (
pEntity As AcadEntity,
<OutAttribute> ByRef pIntersectionBoundaryObjs As Object,
<OutAttribute> ByRef pIntersectionFillObjs As Object,
<OutAttribute> ByRef pBackgroudnObjs As Object,
<OutAttribute> ByRef pForegroudObjs As Object,
<OutAttribute> ByRef pCurveTangencyObjs As Object
)
public:
virtual void GenerateSectionGeometry(
[InAttribute] AcadEntity^ pEntity,
[OutAttribute] Object^% pIntersectionBoundaryObjs,
[OutAttribute] Object^% pIntersectionFillObjs,
[OutAttribute] Object^% pBackgroudnObjs,
[OutAttribute] Object^% pForegroudObjs,
[OutAttribute] Object^% pCurveTangencyObjs
)
abstract GenerateSectionGeometry :
pEntity : AcadEntity *
pIntersectionBoundaryObjs : Object byref *
pIntersectionFillObjs : Object byref *
pBackgroudnObjs : Object byref *
pForegroudObjs : Object byref *
pCurveTangencyObjs : Object byref -> unit
override GenerateSectionGeometry :
pEntity : AcadEntity *
pIntersectionBoundaryObjs : Object byref *
pIntersectionFillObjs : Object byref *
pBackgroudnObjs : Object byref *
pForegroudObjs : Object byref *
pCurveTangencyObjs : Object byref -> unit
Parameters
- pEntity AcadEntity
-
- pIntersectionBoundaryObjs Object
-
- pIntersectionFillObjs Object
-
- pBackgroudnObjs Object
-
- pForegroudObjs Object
-
- pCurveTangencyObjs Object
-
Implements
IAcadSectionGenerateSectionGeometry(AcadEntity,
Object, Object, Object,
Object, Object)
See Also