Curve3dGetSplitCurves Method
|
Retrieves two segments of this curve split at
the specified parameter value.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Curve3d[] GetSplitCurves(
double value
)
Public Function GetSplitCurves (
value As Double
) As Curve3d()
public:
array<Curve3d^>^ GetSplitCurves(
double value
)
member GetSplitCurves :
value : float -> Curve3d[]
Parameters
- value Double
- [in] Parameter value where this curve will be split.
Return Value
Curve3d
Array with two curves that are created after splitting this
curve.
Remarks
If the specified
parameter value does not lie within the parametric interval of the
curve or if it corresponds to the start or end point of the curve,
the array can contain objects that are set to null.
See Also