KnotCollectionGetInterval Method

Returns the knot interval, and the index of the knot interval, containing the point specified by param.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public int GetInterval(
        int order,
        double parameter,
        out Interval interval
)

Parameters

order  Int32
[in] The order of the spline.
parameter  Double
 
interval  Interval
[out] Receives the interval containing the point specified by param.

Return Value

Int32
Remarks
param must lie between the knot values indexed by order -1 and length() - order, where order is the order of the spline.
See Also

©  Bricsys NV. All rights reserved.