Curve2dGetParameterAtLength(Double,
Double, Boolean) Method
|
Retrieves the parameter value of the point
whose arc length distance is the input length.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public double GetParameterAtLength(
double datumParameter,
double length,
bool parameterDirection
)
Public Function GetParameterAtLength (
datumParameter As Double,
length As Double,
parameterDirection As Boolean
) As Double
public:
double GetParameterAtLength(
double datumParameter,
double length,
bool parameterDirection
)
member GetParameterAtLength :
datumParameter : float *
length : float *
parameterDirection : bool -> float
Parameters
- datumParameter Double
- [in] Parameter value.
- length Double
- [in] Sub-interval of the curve.
- parameterDirection Boolean
- [in] Parameter direction.
Return Value
Double
Parameter value as the
double type.
See Also