NurbSurfaceSetControlPoints Method
|
Sets the control points.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetControlPoints(
int iUDegree,
int iVDegree,
Point3dCollection points
)
Public Sub SetControlPoints (
iUDegree As Integer,
iVDegree As Integer,
points As Point3dCollection
)
public:
void SetControlPoints(
int iUDegree,
int iVDegree,
Point3dCollection^ points
)
member SetControlPoints :
iUDegree : int *
iVDegree : int *
points : Point3dCollection -> unit
Parameters
- iUDegree Int32
- [in] New value of the quantity of control points in the
u-direction.
- iVDegree Int32
- [in] New value of the quantity of control points in the
v-direction.
- points Point3dCollection
- [in] New array of control points (in WCS coordinates).
Remarks
If the surface
doesn't contain control point information, the method throws the
eFail exception. The iUDegree or iVDegree
parameters must be equal to the count of control points that this
surface currently stores for u- and v-directions respectively,
otherwise the method throws the eInvalidInput exception. If this method is not
implemented for a specific modeler, throws the eNotImplementedYet exception. The column indexes are
for the v-direction, and row indexes are for the u-direction.
Points in the array should be allocated in the following way:
[0,0], [0,1], ...[0,vCount-1], ..., [uCount-1,0], [uCount-1,1],
...[uCount-1,vCount-1]. This means that control points are set row
by row (v-index varies first).
See Also