SubDMeshSetSubDMesh Method
|
Creates a mesh using input arrays of vertices
and faces.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetSubDMesh(
Point3dCollection vertexArray,
Int32Collection indexArray,
int smoothLevel
)
Public Sub SetSubDMesh (
vertexArray As Point3dCollection,
indexArray As Int32Collection,
smoothLevel As Integer
)
public:
void SetSubDMesh(
Point3dCollection^ vertexArray,
Int32Collection^ indexArray,
int smoothLevel
)
member SetSubDMesh :
vertexArray : Point3dCollection *
indexArray : Int32Collection *
smoothLevel : int -> unit
Parameters
- vertexArray Point3dCollection
- [in] Array of vertices.
- indexArray Int32Collection
- [in] Array of integers that describe faces.
- smoothLevel Int32
- [in] Level of smoothness.
Remarks
Face array is
arranged using the following pattern: the first number is the
number a vertices a face has, the following numbers are indices of
vertices that form a face.
See Also