NurbSurfaceDefinitionIsEqualTo Method

Checks whether this NURBS surface definition is equal to the passed NURBS surface definition.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public bool IsEqualTo(
        NurbSurfaceDefinition a
)

Parameters

a  NurbSurfaceDefinition
[in] NURBS surface definition to compare.

Return Value

Boolean
true if all of the following conditions are met: * Degrees in U are equal, and degrees in V are equal. * Properties in U are equal, and properties in V are equal. * Count of control points in U are equal, and count of control points in V are equal. * Control points are equal. * Weight values are equal. * Knots in U are equal, and knots in V are equal.
See Also

©  Bricsys NV. All rights reserved.