Scale3dExtractScale
Method
|
Returns the scale that corresponds to the
lengths of the column vectors of the specified transformation
matrix.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static Scale3d ExtractScale(
Matrix3d mat
)
Public Shared Function ExtractScale (
mat As Matrix3d
) As Scale3d
public:
static Scale3d ExtractScale(
Matrix3d mat
)
static member ExtractScale :
mat : Matrix3d -> Scale3d
Parameters
- mat Matrix3d
- [in] 3d transformation matrix from which to retrieve
scale.
Return Value
Scale3d
See Also