MassElementCreateObround
Method
|
Sets this mass element as a box that has
custom dimensions. The method also changes the shape type to
ShapeType.FreeForm.
Namespace: Teigha.Aec.DatabaseServices
Assembly: TA_Mgd (in TA_Mgd.dll) Version:
24.2.0.0
Syntax
public void CreateObround(
double width,
double height,
Point3d startPt,
Point3d endPt
)
Public Sub CreateObround (
width As Double,
height As Double,
startPt As Point3d,
endPt As Point3d
)
public:
void CreateObround(
double width,
double height,
Point3d startPt,
Point3d endPt
)
member CreateObround :
width : float *
height : float *
startPt : Point3d *
endPt : Point3d -> unit
Parameters
- width Double
- [in] Box width. Not used, a value of 100 is used to define
box's width.
- height Double
- [in] Box height. Not used, a value of 100 is used to define
box's height.
- startPt Point3d
- [in] Box start point. Together with endPt defines depth and
orientation of the box.
- endPt Point3d
- [in] Box end point. Together with startPt defines depth and
orientation of the box.
See Also