Exception Class

Inheritance Hierarchy
SystemObject
  SystemException
    Teigha.BoundaryRepresentationException

Namespace: Teigha.BoundaryRepresentation
Assembly: TD_MgdBrep (in TD_MgdBrep.dll) Version: 0.0.0.0
Syntax
[SerializableAttribute]
public class Exception : Exception, ISerializable

The Exception type exposes the following members.

Constructors
  Name Description
Public method Exception Initializes a new instance of the Exception class
Public method Exception(ErrorStatus) Initializes a new instance of the Exception class
Public method Exception(ErrorStatus, String) Initializes a new instance of the Exception class
Public method Exception(SerializationInfo, StreamingContext) Initializes a new instance of the Exception class
Public method Exception(ErrorStatus, String, Exception) Initializes a new instance of the Exception class
Top
Properties
  Name Description
Public property ErrorStatus  
Top
Methods
  Name Description
Public method GetObjectData
(Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.